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VS-Ubungen

= Praktikum

Programmieraufgaben fur Android
Drei vorgegebene Ubungsaufgaben
Offenes Projekt

Geht zu 20% in die Gesamtnote ein

= Theoretische Aufgaben

Klausurvorbereitung

Werden gegen Ende der Vorlesung
ausgegeben
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Zeitplan

Al: GUI und Hardware
30. Sep 2011 — 10. Okt 2011 (1.5 Wochen)

A2: Client/Server, Web Services, und die Cloud
10. Okt 2011 — 24. Okt 2011 (2 Wochen)

= A3: Gruppenkommunikation und logische Zeit
24. Okt 2011 — 07. Nov 2011 (2 Wochen)

A4 Offenes Projekt (mit Prasentation)
04. Nov 2011 — 19. Dez 2011 (6.5 Wochen)
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Praktikum

=  Ablauf

Zweier- und Dreiergruppen

Entwicklung im Emulator

Test auf dem Smartphone

Ein HTC Desire pro Gruppe

Dokumentation in Form eines kurzen Papers

= Benotung
Pro Gruppe

«Save-Points»

Werden alle gekennzeichneten Teilaufgaben erfolgreich erfullt,
gehen die Praktikumspunkte nur noch verbessernd ein
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Ein wenig Geschichte

= (09/2003: Android, Inc. Startup in Palo Alto
= (07/2005: Google-Ubernahme von Android

= 11/2007: Open Handset Alliance
HTC, LG, Samsung, Motorola, ...
Texas Instruments, Intel, Nvidia, ...
T-Mobile, Vodafone, Telecom ltalia, ...

= (09/2008: Markteinfuhrung des T-Mobile G1

= 10/2008: Android wird Open Source

Apache-Lizenz erlaubt kommerzielle Entwicklungen

Matthias Kovatsch — ETH Zirich Verteilte Systeme — Praktikum
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Andy Rubin

Co-Founder, Android

G 1 (HTC Dream)
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Android Smartphone-Marktanteil (U.S. 13+)
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Quelle: www.comScore.com
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Android Eckdaten

= Frei erhéaltlich, auch zur Kommerzialisierung
Jeder Handler kann Android erweitern, z.B. «<HTC SenseUl»

= Linux-basiertes OS, Java-basierte Anwendungen
Bekanntes, robustes System
Hochoptimierte Java VM «Dalvik»
Relativ schnelle Anwendungsentwicklung

= Alle Apps sind gleichgestellt!
Keine OS-Kernanwendungen

Systemteile kdnnen komplett ersetzt werden
(Anrufe, SMS, Wecker, WLAN-Verwaltung)
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Versionierung

Version | Releasename | API Level Kernel Releasedatum | Bemerkung

1.1 -

1.5 Cupcake

1.6 Donut
2.X Eclair
2.2 FroYo

2.3.x  Gingerbread

3.xX Honeycomb

Ice Cream

?
e Sandwich
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5—7
8
9-10
11-13

?

2.6.25
2.6.25
2.6.27
2.6.29
2.6.29
2.6.32
2.6.35
2.6.36

?

Sep 2008
Feb 2009
30. Apr 2009
15. Sep 2009
26. Okt 2009
20. Mai 2010
6. Dez 2010
2. Feb 2011

Q4 20117
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Urspriingliche G1 Firmware

G1 Update

Mehr Apps und Sprachen, Soft-Keyboard
Neue Suche, Market, Gesten, VPN
Exchange, BT2.1, Multitouch (z.B. Hero)
JIT, RAM-Support, PUSH, Apps to SD
WebM-Video, Ul-Verbesserungen, NFC

Exklusiv fur Tablets

Zusammenfihrung von 2.3 and 3.x
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Plattform-Interna

Android
Application
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Process
Management

Memory
Management
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Power
Management

Network

Stack DIl &

Keypad
Touchscreen

Other Drivers
WiFi, Bluetooth, Camera,
Audio, Telephony, Flash,

Sensors

Hardware
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Quelle: Conder, Darcey: Android Wireless Application Development, Addison-Wesley (p.24)
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Android Schlusselbegriffe

= «Activity»
Logische Einheit flr eine Benutzerinteraktion
(vgl. Fenster einer PC-Anwendung)
Normalerweise kompletter Bildschirm
Auch ohne Ul moéglich («Service»)

= «View»
Hierarchisches Ul-Element
Konnen in Gruppen kombiniert werden

= «Service»
Hintergrundanwendung, z.B. Musikwiedergabe oder FTP-Server

Matthias Kovatsch — ETH Zirich Verteilte Systeme — Praktikum
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Android Schlusselbegriffe

= «Intent»

Startet oder wechselt zwischen «Activitys»
Passive Datastruktur
Beschreibt, was ausgefuhrt werden soll
Explizit eine bestimmte Klasse
Implizit eine Komponente die zum «Intent-Filter» passt

= «BroadcastRecelver»

Hort auf globale Ereignisse/Intents,
(z.B. «<Headset wurde eingesteckt» vom System)

Weckt oder startet gewiinschte Activity
Oder informiert Benutzer

Matthias Kovatsch — ETH Zirich Verteilte Systeme — Praktikum
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Android Schlusselbegriffe

= «ContentProvider»

= Erlaubt das freigeben/teilen von Daten
(z.B. alle Kontaktdaten)

= Unterstutzt Dateisystem, SQLite, ...
«any way you want»

= Apps greifen per «ContentResolver» auf Daten zu

= Siehe auch
= http://www.youtube.com/watch?v=0QBGfUs9mQYY &feature=user
= http://developer.android.com/quide/topics/fundamentals.html
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Programm-Lebenszyklus &

onCreate()
= Androids Multi-Tasking !
. onStart() & onRestart()
OS verucht Apps so lange wie
moglich laufen zu lassen - ——
Bei Speicherknappheit werden
Prozesse mit niedriger Prioritat Tumning comee 10|
foreground |
b e e n d et [Anomer activity comes | R
in front of the activity
. v "m‘crﬁwﬁf )
™ 7 P iorxrapﬂﬁgons]— onPause ,Gzﬁsrﬁ )
= Activity-Zustande B — o

R u n n I n g ( The activity is no longer visible )

¥

Paused onstop)
Stopped '

Finished/killed onoezrrwn
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Ausgeloste Methoden |

New
Activity

onCreate()

- onApplyThemeResource()

g onWindowAttributesChanged()
-] onContentChanged()

g onStart()

onPostCreate()

'c); onResume()
T onPostResume()

i onWindowFocusChanged(true)

———————— Pull Down Notification Area . .
\ Activity continues
Y

S onWindowFocusChanged(false) running while notification
. Pull Up Notification Area area is visible, but does
Al
i onWindowFocusChanged(true) not have focus
A
A
“Show a Dialog - '
Activity continues
onWindowFocusChanged(false) | running while dialog is
Dismiss the Dialog visible, but does not
have focus

onWindowFocusChanged(true)

onSavelnstanceState()
onPause()
onWindowFocusChanged(false)
onCreateDescription()

onStop()

<«—uojng aWoH 8y} ssaid
Quelle: http:/stuffthathappens.com/blog/2008/11/05/android-activity-lifecycle-updated/
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Ausgeloste Methoden I

!

onSavelnstanceState()
onPause()
O onStop()
n:;- onRetainNonConfigurationinstance()
-] onDestroy()
Q  onCreate()
© onApplyThemeResource()
Q onWindowAttributesChanged()
o onContentChanged()
3 onStart()
Y] onRestorelnstanceState()
g onPostCreate()
3  onResume()
onPostResume()
l onWindowFocusChanged(true)

/
/
!
!
’
7
I
/
L
Paused
1
I
]
\
\
A

v
N
A}
kY
A
A
A
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onSavelnstanceState()
onPause()
onWindowFocusChanged(false)
onCreateDescription()

onStop()

< [|BD 8210/ Buiwoou|

_____ 1. Phone Ringing
2. Phone Call In Progress

onRestart()

onStart()

onResume()

onPostResume()
onWindowFocusChanged(true)

<—Yoeg ¥H 40 ‘dn Buey

Quelle: http://stuffthathappens.com/blog/2008/11/26/android-lifecycle-triggers-part-2/
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Nutzliche Quellen

= Android-Developers: developer.android.com
= «The Guide» (Einfuhrung): /guide/index.html
= «Resources» (Tutorials): /resources/index.html
= Videos: /videos/index.htm!

= Android-Blogs
= http://android-developers.blogspot.com
= http://www.androidquys.com/

= Google-Suche
= StackOverflow

Matthias Kovatsch — ETH Zirich Verteilte Systeme — Praktikum
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Gruppen

= Anzahl unserer HTC Desires begrenzt (30)

= Wer hat selber ein Android-Smartphone?
Bitte alsbald eure Gruppe melden

= Zweiergruppen solange wie mdglich
= Danach Drelergruppen
= HTC Desire Ausgabe

Aktueller Stand unter

Montag 14 — 16 Uhr CNB H 103.2
Dienstag 10— 12 Uhr CNB H 103.2
Mittwoch 10 — 12 Uhr CNB H 103.2

Donnerstag 14 — 16 Uhr CNB H 108
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HTC Desire

= Zunachst die Batterie voll laden

= WLAN einrichten
«Settings > Wireless & networks > Wi-Fi settings»

Over-the-Air-Update auf Android 2.29.405.5
«Settings > About Phone > System software updates > Check now»

= Debug-Modus aktivieren
«Settings > Applications > Development > USB debugging»

= Macht euch mit dem Geréat vertraut

Matthias Kovatsch — ETH Zirich Verteilte Systeme — Praktikum
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Installation der Toolchain

= Java SE JDK 6

= Android SDK

Irgendwohin entpacken

= Eclipse 3.7 «Indigo» («Classic» empfohlen)

ADT Plugin hinzufligen («Help > Install New Software...»)

«Work with» location https://dl-ssl.google.com/android/eclipse/
SDK angeben («Window > Preferences > Android»)
API 8 Pakete install. («Window > Android SDK and AVD Manager»)
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Windows

= ADB-Treiber

-
&l Device Manager

File Action View Help

e mE]

» 2 Jungo
> = Keyboards

- Mice and other pointing devices
=] Modems

| ¥

Moanitors

Network adapters
AT es

BT oth Peripheral Device
[l PCISimple Communications Controller
B Portable Devices

577 Ports (COM & LPT)

» J2) Processors

Sound, video and game controllers

M System devices
§ Universal Serial Bus controllers

!
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Update Driver Software - ADB
&/ O e - — -

[E=)

= " —
&5 U Update Driver Software - ADB
L e

[—
@ 1l Update Driver Seftware - ADB
- — - -

How do you want to search for driver software?

= Search automatically for updated driver software
Windows will search your computer and the Intemet for the latest driver software
foryour device, unless you've disabled this feature in your device installation
settings.

2 Browse my computer for driver software
Locate and install driver software manually.

Browse for driver software on your computer

Search for driver software in this location:

| v | Browse..

[¥] Include subfolders

2 Let me pick from a list of device drivers on my computer
This list will show installed driver software compatible with the device, and all driver
software in the same category as the device.

Next

Select your device's type from the list below.

¥ ADB Interface
& Android Phone
§ AVC Devices

3 Batteries
2/Biometric Devices
) Bluetooth Radios
Computer

(a Disk drives
&, Display adapters

|5 DriverInterface

——

@ 1 Update Driver Software - ADB
L e as

() 1 Update Driver Software - ADB

——
@ [l Update Driver Software - ADE
- — - -

Select the device driver you want to install for this hardware.

disk that contains the driver you want to install, click Have Disk.

(Retrieving a list of all devices)

® E Select the manufacturer and model of your hardware device and then click Next. If you have a

Matthias Kovatsch — ETH Zurich

Select the device driver you want to install for this hardware.

- g - N
E: Install From Disk - - e o hove
et the mamfectres sl dk andthen [ gy
e et e conet die e seecd b, (0]
(Retricv} |
Copy manufacturer’s fies from
I <paihto> \androidsckindows wsb_dmver, I
\ Disk
—

Mext

Select the device driver you want to install for this hardware.

disk that contains the driver you want to install, click Have Disk.

° E Select the manufacturer and model of your hardware device and then click Next. If you have a

Model
5] Android ADB Interface

Verteilte Systeme — Praktikum

[=] This driver has an Authenticode(tm) signature.
Tell me why driver signing is important

.com/sdk/win-usb.htmi

/Ideveloper.androi

Siehe auch hitp
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Ubuntu Linux

= USB-Konfiguration

Erstelle /etc/udev/rules.d/51-android.rules als Superuser
Inhalt flr «Gutsy»/«Hardy»

SUBSYSTEM=="usb", SYSFS{idVendor}=="0bb4", MODE="0666"

Inhalt fir «<Dapper»
SUBSYSTEM=="usb device", SYSFS{idVendor}=="0bb4", MODE="0666"

Zugriffsrechte anpassen

chmod a+r /etc/udev/rules.d/51l-android.rules
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Siehe auch
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(Computerraume)

= Windows

Drivers, Eclipse, and ADT Plugin are installed "
Download and extract Android SDK to your home directory
Set up SDK location in Eclipse

Install APl 8 packages

= Linux
USB configuration already done v

Download and extract Android SDK to your home directory (or /local/)
Red Hat tool ignores empty folders - recreate «platforms» and «add-ons» folders

Update Eclipse («Help > Install New Software»)
Software Site http://download.eclipse.org/eclipse/updates/3.5
Install ADT Plugin

Set up SDK location
Install APl 8 packages
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Test der Toolchain

= Kann ein Android-Projekt angelegt werden?

= Kompilieren die mitgelieferten «Sample»-Projekte?

= Funktioniert der USB-Treiber?

= Werden die «<Sample»-Projekte installiert und starten?

= |egt ein «virtual device» an und startet den Emulator!
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Android-Tutorial

= Freitag, 30. Sep 2011

= Einfahrung in die Android-Programmierung
» «Live-Hacking»
Mit euch - Toolchain installieren!

= Erste Aufgabe
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